HDU 1096 A+B for Input-Output Practice (VIII)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 182242    Accepted Submission(s): 54512


Problem Description
Your task is to calculate the sum of some integers.
 

 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

 

Sample Input
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 

 

Sample Output
10 15 6
 

 

Author
lcy
 思路:好一个zz的问题
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,ans;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        int m;scanf("%d",&m);
        for(int j=1;j<=m;j++){
            int x;scanf("%d",&x);
            ans+=x;
        }
        if(i<n)    cout<<ans<<endl<<endl;
        else cout<<ans<<endl;ans=0;
    } 
}

 

posted @ 2018-04-14 14:51  一蓑烟雨任生平  阅读(141)  评论(0编辑  收藏  举报