POJ 3436 ACM Computer Factory

                              ACM Computer Factory
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8632   Accepted: 3140   Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part jDi,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.

Source

Northeastern Europe 2005, Far-Eastern Subregion
题意:
有p个零部件,n台机器
接下来n行,每行
第一个数字表示这台机器最多能组装几个零部件,
后面p个数,表示要由这台机器组装,零部件要满足的条件 ,可能为0,1,2,分别表示这个零部件必须还没有组装,必须已经组装,组装不组装都行
后面再p个数 ,表示由这台机器组装完毕后,零部件的情况,可能为0,1,分别表示 这个零部件没有组装,已经组装。
思路:网络流先拆点再跑最大流。
建图:
1.把每台机器拆成两个点,第i台机器与其拆点的i+n台机器连一条流量为机器产量的边。
2.如果第i台机器要生产的零件是全部没有生产过的,就把i向源点连一条流量为inf的边。
3.如果第i台机器生产后的零件为全部生产完成的,就把i+n向汇点连一条流量为inf的边。
4.如果第i台机器生产完之后的零件状况与第j台机器生产之前的零件状况相互吻合,就从i+n向j连一条流量为inf的边。
 第一个样例的图如下所示:
求各位大佬看看为什么wa了。
#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 30000
using namespace std;
int p,n,tot=1;
int src,decc,ans;
int out[MAXN][4];
int cur[MAXN],lev[MAXN];
int be[MAXN][11],en[MAXN][11];
int to[MAXN*2],cap[MAXN*2],net[MAXN*2],head[MAXN];
void clearn(){
    tot=1;ans=0;
    memset(head,0,sizeof(head));
}
void add(int u,int v,int w){
    to[++tot]=v;cap[tot]=w;net[tot]=head[u];head[u]=tot;
    to[++tot]=u;cap[tot]=0;net[tot]=head[v];head[v]=tot;
}
bool bfs(){
    queue<int>que;
    for(int i=src;i<=decc;i++){
        lev[i]=-1;
        cur[i]=head[i];
    }
    que.push(src);lev[src]=0;
    while(!que.empty()){
        int now=que.front();
        que.pop();
        for(int i=head[now];i;i=net[i])
            if(lev[to[i]]==-1&&cap[i]>0){
                que.push(to[i]);
                lev[to[i]]=lev[now]+1;
                if(to[i]==decc)    return true;
            }
    }
    return false;
}
int dinic(int now,int flow){
    if(now==decc)    return flow;
    int rest=0,detal;
    for(int & i=cur[now];i;i=net[i])
        if(lev[to[i]]==lev[now]+1&&cap[i]>0){
            detal=dinic(to[i],min(flow-rest,cap[i]));
            if(detal){
                rest+=detal;
                cap[i]-=detal;
                cap[i^1]+=detal;
                if(rest==flow)    break;
            }
        }
    if(rest!=flow)    lev[now]=1;
    return rest;
}
int main(){
    while(scanf("%d%d",&p,&n)!=EOF){
        src=0;decc=2*n+1;
        for(int i=1;i<=n;i++){
            int m;scanf("%d",&m);
            add(i,i+n,m);
            for(int j=1;j<=p;j++)    scanf("%d",&be[i][j]);
            for(int j=1;j<=p;j++)    scanf("%d",&en[i][j]);
        }
        for(int i=1;i<=n;i++){
            int sum1=0,sum2=0;
            for(int j=1;j<=p;j++){
                if(be[i][j]==0)    sum1++;
                if(en[i][j]==1)    sum2++;
            }
            if(sum1==p)    add(src,i,0x7f7f7f7f);
            if(sum2==p)    add(i+n,decc,0x7f7f7f7f);
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i!=j){
                    int sum=0;
                    for(int k=1;k<=p;k++)
                        if(en[i][k]==be[j][k]||en[i][k]==2||be[j][k]==2)    sum++;
                    if(sum==p)    add(i+n,j,0x7f7f7f7f);
                }
        while(bfs())    
            ans+=dinic(src,0x7f7f7f7f);
        printf("%d ",ans);
        int sum=0;
        for(int i=1;i<=n;i++){
            for(int j=head[n+i];j;j=net[j]){
                if(to[j]==decc||cap[j]==0x7f7f7f7f||to[j]==i)    continue;
                sum++;out[sum][1]=i;
                out[sum][2]=to[j];
                out[sum][3]=0x7f7f7f7f-cap[j];
            }
        }
        printf("%d\n",sum);
        for(int i=1;i<=sum;i++)
            printf("%d %d %d\n",out[i][1],out[i][2],out[i][3]);
        clearn();
    }
}

 

posted @ 2018-01-13 10:44  一蓑烟雨任生平  阅读(176)  评论(0编辑  收藏  举报