洛谷 P3378 【模板】堆

题目描述

如题,初始小根堆为空,我们需要支持以下3种操作:

操作1: 1 x 表示将x插入到堆中

操作2: 2 输出该小根堆内的最小数

操作3: 3 删除该小根堆内的最小数

输入输出格式

输入格式:

 

第一行包含一个整数N,表示操作的个数

接下来N行,每行包含1个或2个正整数,表示三种操作,格式如下:

操作1: 1 x

操作2: 2

操作3: 3

 

输出格式:

 

包含若干行正整数,每行依次对应一个操作2的结果。

 

输入输出样例

输入样例#1: 复制
5
1 2
1 5
2
3
2
输出样例#1: 复制
2
5

说明

时空限制:1000ms,128M

数据规模:

对于30%的数据:N<=15

对于70%的数据:N<=10000

对于100%的数据:N<=1000000(注意是6个0。。。不过不要害怕,经过编者实测,堆是可以AC的)

样例说明:

故输出为2、5

手写堆

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 1000010
using namespace std;
int n,num;
int heap[MAXN];
void insert(int x){
    heap[++num]=x;
    int p=num;
    while(p>1&&heap[p/2]>x){
        heap[p]=heap[p/2];
        p/=2;
    }
    heap[p]=x;
}
void up(int now){
    int l=now*2,r=now*2+1;
    int minn=now;
    if(l<=num)
        minn=heap[minn]<heap[l]?minn:l;
    if(r<=num)
        minn=heap[minn]<heap[r]?minn:r;
    if(minn!=now){
        swap(heap[minn],heap[now]);
        up(minn);
    }
}
void pop(){
    heap[1]=heap[num--];
    up(1);
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        int x,y;
        scanf("%d",&x);
        if(x==1){
            scanf("%d",&y);
            insert(y);
        }
        else if(x==2)    cout<<heap[1]<<endl;
        else    pop();
    }
}

STL

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
priority_queue<int,vector<int>,greater<int> >que;
int n;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        int x,y;
        scanf("%d",&x);
        if(x==1){
            scanf("%d",&y);
            que.push(y);
        }
        else if(x==2)    cout<<que.top()<<endl;
        else que.pop();
    }
}

 

posted @ 2017-11-06 16:17  一蓑烟雨任生平  阅读(152)  评论(0编辑  收藏  举报