洛谷 P3147 [USACO16OPEN]262144

题目描述

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of NN positive integers (2 \leq N\leq 262,1442N262,144), each in the range 1 \ldots 40140. In one move, Bessiecan take two adjacent numbers with equal values and replace them asingle number of value one greater (e.g., she might replace twoadjacent 7s with an 8). The goal is to maximize the value of thelargest number present in the sequence at the end of the game. Pleasehelp Bessie score as highly as possible!

Bessie喜欢在手机上下游戏玩(……),然而她蹄子太大,很难在小小的手机屏幕上面操作。

她被她最近玩的一款游戏迷住了,游戏一开始有n个正整数,(2<=n<=262144),范围在1-40。在一步中,贝西可以选相邻的两个相同的数,然后合并成一个比原来的大一的数(例如两个7合并成一个8),目标是使得最大的数最大,请帮助Bessie来求最大值。

输入输出格式

输入格式:

 

The first line of input contains NN, and the next NN lines give the sequence

of NN numbers at the start of the game.

 

输出格式:

 

Please output the largest integer Bessie can generate.

 

输入输出样例

输入样例#1:
4
1
1
1
2
输出样例#1:
3

说明

In this example shown here, Bessie first merges the second and third 1s to

obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

not optimal to join the first two 1s.

思路:

这个题状态比较奇妙,不妨设一个f[i][j]表示到第i个数,得到数值为j,向右合并的最右端点。

 

方程f[i][j]=f[f[i][j-1]][j-1];这个方程很像倍增。

 

然后这个j比较小,因为两个合并之后得到的数只大1,所以可以跑过去。

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int x,n,ans;
int f[60][270000];
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&x);
        f[x][i]=i+1;
    }
    for(int i=2;i<=58;i++)
        for(int j=1;j<=n;j++){
            if(!f[i][j])    f[i][j]=f[i-1][f[i-1][j]];
            if(f[i][j])    ans=i;
        }
    cout<<ans;
}

 

posted @ 2017-09-27 21:01  一蓑烟雨任生平  阅读(205)  评论(0编辑  收藏  举报