HDU 2955 Robberies

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25689    Accepted Submission(s): 9476

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 
Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 
Sample Output
2 4 6
 
Source
 
Recommend
gaojie   |   We have carefully selected several similar problems for you:  2602 1203 2159 2844 1171 
 
 思路:由于各个银行的被抓概率独立,所以要用独立概率的乘法计算总的被抓概率.。假设抢了1,2,3银行,被抓概率分别为P1,P2,P3.那么总的被抓概率是1-不被抓的概率,即为:1-(1-P1)*(1-P2)*(1-P3)。令dp[i][j]=p,表示决策完前i个银行,且抢到了j价值的物品时不被抓的最大概率为p。

  d[i][j] = max(d[i-1][j],d[i-1][j-v[i]]*(w[i]))  其中w[i]是抢第i个银行不被抓的概率

初值d[0][x]=1。最终我们从大到小遍历j,只有d[n][j]>=1-P,那么j就是我们能获得的最大价值。

吐槽:果然,我是真的菜,思路竟然跑偏辣么大,都︿( ̄︶ ̄)︿起来了。数学基础差,竟然忘了概率是乘的,不是加的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,t,sum,money[200];
double m,dis[200],f[100000];
int main(){
    scanf("%d",&t);
    while(t--){
        memset(f,0,sizeof(f));
        memset(dis,0,sizeof(dis));
        memset(money,0,sizeof(money));
        sum=0;
        scanf("%lf%d",&m,&n);
        for(int i=1;i<=n;i++){
            scanf("%d%lf",&money[i],&dis[i]);
            dis[i]=1.0-dis[i];
            sum+=money[i];
        }
        f[0]=1;
        for(int i=1;i<=n;i++)
            for(int j=sum;j>=money[i];j--)
                f[j]=max(f[j],f[j-money[i]]*dis[i]);
        for(int i=sum;i>=0;i--)
            if(f[i]>=1.0-m){
                printf("%d\n",i);
                break;
            }
    }
}

 

posted @ 2017-08-26 11:07  一蓑烟雨任生平  阅读(127)  评论(0编辑  收藏  举报