POJ 1654 Area [多边形面积]

Area
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19642   Accepted: 5376

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2. 

For example, this is a legal polygon to be computed and its area is 2.5: 

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

Source


裸题
选第一个点为基准点 其他相邻两个点叉积
卡内存 全程ll也是醉了
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;
typedef long long ll;
const int N=1e6+5;
const double eps=1e-8;
inline int read(){
    char c=getchar();int x=0,f=1;
    while(c<'0'||c>'9'){if(c=='-')f=-1; c=getchar();}
    while(c>='0'&&c<='9'){x=x*10+c-'0'; c=getchar();}
    return x*f;
}
inline int sgn(double x){
    if(abs(x)<eps) return 0;
    else return x<0?-1:1;
}
struct Vector{
    ll x,y;
    Vector(ll a=0,ll b=0):x(a),y(b){}
};
typedef Vector Point;
ll Cross(Vector a,Vector b){
    return a.x*b.y-a.y*b.x;
}

char s[N];
int n,
dx[11]={0,-1, 0, 1,-1, 0, 1,-1, 0, 1},
dy[11]={0, 1, 1, 1, 0, 0, 0,-1,-1,-1};
Point last,now;
int main(int argc, const char * argv[]) {
    int T=read();
    while(T--){
        ll area=0;
        scanf("%s",s+1);
        n=strlen(s+1);n-=2;
        if(n<=0){puts("0");continue;}
        ll x=0,y=0;
        last=Point(x,y);
        for(int i=1;i<=n;i++){
            x+=dx[s[i]-'0'];y+=dy[s[i]-'0'];
            now=Point(x,y);
            if(i!=1) area+=Cross(now,last);
            last=now;
        }
        if(area<0) area=-area;
        if(area%2==0) printf("%lld\n",area/2);
        else printf("%lld.5\n",area/2);
    }
    return 0;
}

 

 
posted @ 2017-01-28 12:38  Candy?  阅读(224)  评论(0编辑  收藏  举报