POJ1985Cow Marathon[树的直径]

Cow Marathon
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 5117   Accepted: 2492
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

Source


裸题
换一种DP写法
小心不能用f[j][1]来更新f[i],因为是从i节点的不同子树中选
//
//  main.cpp
//  poj1985
//
//  Created by Candy on 9/21/16.
//  Copyright ? 2016 Candy. All rights reserved.
//

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=5e4+5;
int read(){
    char c=getchar();int x=0,f=1;
    while(c<'0'||c>'9'){if(c=='-')f=-1; c=getchar();}
    while(c>='0'&&c<='9'){x=x*10+c-'0'; c=getchar();}
    return x*f;
}
int n,m,u,v,w,ans=0; char c[2];
struct edge{
    int ne,v,w;
}e[N<<1];
int h[N],cnt=0;
void ins(int u,int v,int w){
    cnt++;
    e[cnt].v=v; e[cnt].w=w; e[cnt].ne=h[u]; h[u]=cnt;
    cnt++;
    e[cnt].v=u; e[cnt].w=w; e[cnt].ne=h[v]; h[v]=cnt;
}
int f[N][2];
void dp(int u,int fa){
    f[u][0]=0;
    for(int i=h[u];i;i=e[i].ne){
        int v=e[i].v,w=e[i].w;
        if(v==fa) continue;
        dp(v,u);
        if(f[v][0]+w>f[u][0]){
            f[u][1]=f[u][0];
            f[u][0]=f[v][0]+w;
        }else{
            if(f[v][0]+w>f[u][1]) f[u][1]=f[v][0]+w;
        }
    }
}
int main(int argc, const char * argv[]) {
    n=read();m=read();
    for(int i=1;i<=m;i++){
        u=read();v=read();w=read();
        ins(u,v,w);
        scanf("%s",c);
    }
    memset(f,-1,sizeof(f));
    dp(1,0);
    for(int i=1;i<=n;i++) ans=max(ans,f[i][1]+f[i][0]);
    printf("%d",ans);
    return 0;
}

 

posted @ 2016-09-21 17:03  Candy?  阅读(229)  评论(0编辑  收藏  举报