POJ2184 Cow Exhibition[DP 状态负值]

Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12420   Accepted: 4964

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

---------------------------------------------------------------------------------------------------
f[i][j]表示i头牛,TS为j时TF的值  可能有负值,用一个shift=1e5表示原来的0,ng和ps表示负和正的总和,上下界就有了
愉快地01背包
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=102,V=N*2000,shift=1e5,INF=1e9;
int n,s[N],f[N],ps=0,ng=0,ans=0;//ps+shift ng+shift
int d[V];
void dp(){
    for(int i=ng+shift;i<=ps+shift;i++) d[i]=-INF;
    d[shift]=0;
    for(int i=1;i<=n;i++){//printf("i %d\n",i);
        if(s[i]>=0) for(int j=ps+shift;j>=s[i]+ng+shift;j--) 
                    d[j]=max(d[j],d[j-s[i]]+f[i]);//,printf("j %d %d\n",j-shift,d[j]);
        if(s[i]<0)  for(int j=ng+shift;j<=s[i]+ps+shift;j++) 
                    d[j]=max(d[j],d[j-s[i]]+f[i]);//,printf("j %d %d\n",j-shift,d[j]);
    }
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){scanf("%d%d",&s[i],&f[i]);if(s[i]>=0) ps+=s[i];else ng+=s[i];}
    dp();
    for(int i=shift;i<=ps+shift;i++) if(d[i]>=0) ans=max(ans,d[i]+i-shift);
    cout<<ans;
    
    //cout<<"\n\n";
    //cout<<ps<<" "<<ng;
} 

 

posted @ 2016-08-24 17:20  Candy?  阅读(183)  评论(0编辑  收藏  举报