HDU-1506 Largest Rectangle in a Histogram

         对于每一块木板,Area=height[i]*(j-k+1)其中,j<=x<=k,height[x]>=height[i];找j,k成为关键,一般方法肯定超时,利用动态规划,如果它左边高度大于等于它本身,那么它左边的左边界一定满足这个性质,再从这个边界的左边迭代下去
   http://acm.hdu.edu.cn/showproblem.php?pid=1506 

           Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9550    Accepted Submission(s): 2633

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
 
Sample Output
8
4000
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int l[100010],r[100010];
int  a[100010];
int main()
{
	   int t,i;
	 long long  m,max;
	while(scanf("%d",&t)!=EOF&&t!=0)
	{
		max=0;
		memset(a,0,sizeof(a));
	   for(i=1;i<=t;i++)
	       scanf("%d",&a[i]);
	    for(i=1;i<=t;i++)
       {       l[i]=i;
           while(l[i]>1&&a[l[i]-1]>=a[i])
               l[i]=l[l[i]-1];
       }
       for(i=t;i>=1;i--)
       {
		   r[i]=i;
           while(r[i]<t&&a[r[i]+1]>=a[i])
               r[i]=r[r[i]+1];    
       }
	   for(i=1;i<=t;i++)
	   {
		   m=(long long)(r[i]-l[i]+1)*a[i];
		   if(max<m)
			  max=m;
	   }
	  cout<<max<<endl;
	}
	return 0;
}
//  4  1000000000  1000000000  1000000000  1000000000

 

posted @ 2014-02-23 20:48  疯狂的癫子  阅读(196)  评论(0编辑  收藏  举报