HDU-2711 Lost Cows

                         Lost Cows

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 402    Accepted Submission(s): 203

Problem Description
N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.
Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.
Given this data, tell FJ the exact ordering of the cows.
 
Input
* Line 1: A single integer, N
* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
 
Output
* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
 
Sample Input
5
1
2
1
0
 
Sample Output
2
4
5
3
1
#include<stdio.h>
#define maxn 500004
int a[1000000],s[1000000],n;
struct node
{
    int left,right;
    int num;
};
node tree[3*maxn];
void build(int left,int right,int i)
{
    tree[i].left =left;
    tree[i].right=right;
    tree[i].num =right-left+1;
    if(tree[i].left ==tree[i].right )
        return ;
    build(left,(left+right)/2,2*i);
    build((left+right)/2+1,right,2*i+1);
}
int insert(int i,int r)
{
       tree[i].num--;
     if(tree[i].left==tree[i].right)
            return tree[i].left ;
     if(tree[2*i].num>=r)
        insert(i*2,r);
     else
        insert(i*2+1,r-tree[2*i].num);
}
int main()
{
    int i;
   while(~scanf("%d",&n))
   {
       a[1]=0;
      for(i=2;i<=n;i++)
        scanf("%d",&a[i]);
      build(1,n,1);
    for(i=n;i>=1;i--)
       s[i]=insert(1,a[i]+1);
     for(i=1;i<=n;i++)
        printf("%d\n",s[i]);

   }
   return 0;
}

 

posted @ 2013-11-11 20:03  疯狂的癫子  阅读(262)  评论(0编辑  收藏  举报