HDU-1358 Period

    http://acm.hdu.edu.cn/showproblem.php?pid=1358

学习重要的是: len 如果能整除 len-next[len],
 那么重复的次数就是  len/(len-next[len])
 不能整除就没有重复串  。           

                           Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2168    Accepted Submission(s): 1071

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 
Sample Input
3
aaa
12
aabaabaabaab
0
 
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
 
Recommend
JGShining
 
#include <stdio.h>
char s[1000005];
int next[1000005];
void getnext(int x) {
 int i=0,j=-1;
 next[0]=-1;
  while(i<x) {
   if(j==-1||s[i]==s[j]){
    i++;j++;
    
      next[i]=j;
   }
   else j=next[j];
  }
}

int main()
{
 int i,n,p=0;
 while(~scanf("%d",&n)&&n!=0) {
  scanf("%s",s);
  getnext(n);
  printf("Test case #%d\n",++p);
  for(i=2;i<=n;i++){      //关键在这里 50~56
  //类似 len 如果能整除 len-next[len],
  //那么重复的次数就是  len/(len-next[len])
  //不能整除就没有重复串
   int t=i%(i-next[i]);//j=i-next[i]就是看i和next[i] 之间有多少个字母,
   //然后如果i%j==0,则说明i之前一定有一个周期性的字串,次数为i/j.
   int k=i/(i-next[i]);
   if(t==0&&k>1) printf("%d %d\n",i,k);
  }
  printf("\n");
 }
}

 

posted @ 2013-10-14 21:37  疯狂的癫子  阅读(133)  评论(0编辑  收藏  举报