hdu1495 非常可乐

非常可乐

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18853    Accepted Submission(s): 7637


Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 

 

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 

 

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 

 

Sample Input
7 4 3 4 1 3 0 0 0
 

 

Sample Output
NO 3
#include <iostream>
#include <cstring>
#include <string>
#include <queue>
using namespace std;
int s,n,m,half;
int a[3];
int v[101][101][101];
struct node
{
    int b[3],s;
}p,t;
bool pf(int x,int y,int z)
{
    if(x==half&&y==half) return 1;
    if(x==half&&z==half) return 1;
    if(z==half&&y==half) return 1;
    return 0;
}
void bfs()
{
    queue<node>q;
    p.b[0]=s;p.b[1]=0;p.b[2]=0;p.s=0;
    q.push(p);
    v[s][0][0]=1;
    while(!q.empty())
    {
        p=q.front();q.pop();
        int i,j;
        for(i=0;i<3;i++)
        {
            if(p.b[i]<=0) continue;//有可乐才可以倒
            for(j=0;j<3;j++)
            {
                if(i==j) continue;
                t=p;//否则会改变原值,6个状态一起执行,同时的
                //能倒满
                if(t.b[i]>=a[j]-t.b[j])
                {
                    t.b[i]=t.b[i]-(a[j]-t.b[j]);
                    t.b[j]=a[j];
                }
                else //倒不满
                {
                    t.b[j]=t.b[j]+t.b[i];
                    t.b[i]=0;
                }
                t.s++;
                if(pf(t.b[0],t.b[1],t.b[2])) {cout<<t.s<<endl;return;}
                if(v[t.b[0]][t.b[1]][t.b[2]]==0)
                {
                    v[t.b[0]][t.b[1]][t.b[2]]=1;
                    q.push(t);
                }
            }
        }
    }
    cout<<"NO"<<endl;
}
int main()
{
    while(cin>>s>>n>>m)
    {
        if(s%2)  {cout << "NO"<<endl;continue;} 
        half=s/2;
        if(s==0&&n==0&&m==0) break;
        a[0]=s;a[1]=n;a[2]=m;
        memset(v,0,sizeof(v));
        bfs();
    }
    return 0;
}

 

posted on 2018-02-03 22:53  蔡军帅  阅读(102)  评论(0编辑  收藏  举报