Oulipo(Hash入门第一题 Hash函数学习)

Hash,一般翻译做散列、杂凑,或音译为哈希,就是把任意长度的输入(又叫做预映射, pre-image),通过散列算法,变换成固定长度的输出,该输出就是散列值。这种转换是一种压缩映射,也就是,散列值的空间通常远小于输入的空间,不同的输入可能会散列成相同的输出,而不可能从散列值来唯一的确定输入值。简单的说就是一种将任意长度的消息压缩到某一固定长度的消息摘要的函数。

 

这里就只介绍一种Hash函数,其实有好多种,但是目前只学了这一种。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1686

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26635    Accepted Submission(s): 10252


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

 

Sample Output
1 3 0
 

 

Source
 
题目大意:A串在B串出现了多少次 

看代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
typedef unsigned long long ULL;
const int maxn=1e6+5;
const ULL mod=1e9+7;
const ULL Ha=13331;
ULL xp[maxn];
ULL Hash1[maxn],Hash2[maxn];
void Init()//xp[i] 等于Ha^i   为了后面的计算(看不懂先接着看)
{
    xp[0]=1;
    for(int i=1;i<maxn;i++) xp[i]=xp[i-1]*Ha;
    return ;
}
void make_Hash(string s,ULL Hash3[])//给一个串每个位置一个Hash值
{
    int len=s.size();
    Hash3[len]=0;
    for(int i=len-1;i>=0;i--)
    {
        Hash3[i]=(Hash3[i+1]*Ha+(s[i]-'A'+1));
    }
    return ;
}
ULL get_Hash(ULL n,ULL len,ULL Hash[])//得到那个子串的Hash值
{

    return (Hash[n]-Hash[n+len]*xp[len]);//这里值得思考一下  为什么*xp[len]呢? 最后你会发现这样子处理得到的结果可以解决第一个串出现在中间的情况
}
int main()
{
    Init();
    string s1,s2;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        ULL ans=0;
        //scanf("%s",s1,s2);
        cin>>s1>>s2;
        make_Hash(s1,Hash1);
        make_Hash(s2,Hash2);
        ULL len1=s1.size();
        ULL len2=s2.size();
        ULL tmp=get_Hash(0,len1,Hash1);
        //cout<<"tmp "<<tmp<<endl;
        for(int i=0;i+len1-1<len2;i++)//直接取出相同长度的出来比较就好了 
        {
            //cout<<i<<" "<<get_Hash(i,len1,Hash2)<<endl;
            if(get_Hash(i,len1,Hash2)==tmp) ans++;
        }

        printf("%llu\n",ans);
    }
    return 0;
}

 

posted @ 2019-03-14 19:14  执||念  阅读(404)  评论(0编辑  收藏  举报