HDU 1711:Number Sequence(KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 

算法:KMP匹配

#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 1e6+7;

int a[maxn];
int b[maxn];
int Next[maxn];

void getNext(int len) {
    int i = 0, j = -1;
    Next[0] = -1;
    while(i < len) {
        while(j != -1 && b[i] != b[j]) {
            j = Next[j];
        }
        Next[++i] = ++j;
    }
}

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        int n, m;
        scanf("%d %d", &n, &m);
        for(int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
        }
        for(int j = 0; j < m; j++) {
            scanf("%d", &b[j]);
        }
        getNext(m);
        int i = 0, j = 0;
        int ans = -1;
        while(i < n) {
            while(j != -1 && a[i] != b[j]) {
                j = Next[j];
            }
            i++, j++;
            if(j >= m) {
                ans = i - j + 1;
                break;
            }
        }
        printf("%d\n" ,ans);
    }
    return 0;
}

 

posted @ 2019-08-05 19:24  不会fly的pig  阅读(133)  评论(0编辑  收藏  举报