(POJ 3169) Layout(差分约束系统)

Layout
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13312   Accepted: 6391

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
 
差分约束裸题,给你n个变量和它们之间的一些关系,ai-aj<=k或ai-ak>=k
可以转化成ai<=或>=aj+k
看到这种形式的不等式,我们不难想出在求单源最短路径时,每个点权值(最短路径)更新所需要条件的形式,和这个不等式非常的相似。
因此就可以把这种差分约束问题转化为图论中单元最短路径的问题求解。
将每个a值看做一个点的权值,若有ai<=k+aj,就将其看成j到i之间有一条长度为k的有向边,转化为一个有向图来求解
因为本体给的条件中有大于号也有小于号,统一改成大于(最长路)或者小于号(最短路),改完之后注意k要变成相反数;
用spfa求解出最后答案
 
#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
#include<map>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#define LL long long
#define mod 1000000007
#define inf 0x3f3f3f3f

using namespace std;
int tu[1010][1010];
int dis[1010];
int n;

bool spfa()
{
    int vis[1010]={0};
    queue<int> run;
    run.push(1);
    dis[1]=0;
    while(!run.empty())
    {
        int tem=run.front();
        run.pop();
        if(++vis[tem]>n)
            return false;
        for(int i=1;i<=n;i++)
        {
            int p=tu[tem][i];
            if(p==inf)
                continue;
            if(dis[i]>dis[tem]+p)
            {
                run.push(i);
                dis[i]=dis[tem]+p;
            }
        }
    }
    return true;
}

int main()
{
    int ml,md;
    while(~scanf("%d%d%d",&n,&ml,&md))
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                tu[i][j]=inf,dis[i]=inf;

        for(int i=1;i<=ml;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            tu[a][b]=c;
        }
        for(int i=1;i<=md;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            tu[b][a]=-c;
        }
        if(!spfa())
            printf("-1\n");
        else
        {
            if(dis[n]==inf)
                printf("-2\n");
            else
                printf("%d\n",dis[n]);
        }
    }
    return 0;
}

 

posted @ 2018-03-06 20:50  海哥天下第一  阅读(182)  评论(0编辑  收藏  举报