随笔分类 - 运维
1
摘要:error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools” 下载官方vc++工具并安装:visualcppbuildtools full.exe 如果还是报这个错,可能是之前
阅读全文
摘要:系统:deepin 因为apt中找不到3.6.10版本,因此采用源码安装 "安装教程" 安装完后,使用pip时报错: 参考百度教程: "关于Ubuntu中运行python报错No module named _sysconfigdata_nd" ~~解决方案~~: 复制系统自带的3.5版本的该文件 成
阅读全文
摘要:Jenkins通过curl自动推送文件&gitlab自动触发构建 需求 通过url参数,自动将gitlab文件推送到指定环境的机器目录下 可用变量 http://server/env vars.html 工作目录 配置 安装jenkins、gitlab、ansible jenkins安装buildW
阅读全文
摘要:安装 可事先把数据库装好,再通过官网教程安装zabbix "官网教程" 数据库我选择mysql,亦可选择postgresql "数据库安装" 小结汇总 1. 数据库连接报错:select 需要将sql数据导入数据库: 若这个语句无法执行,可先将create.sql.gz解压 ,解压后,进入数据库 ,
阅读全文
摘要:虚拟机中安装了Gitlab,gitlab中也有nginx,导致端口冲突,用curl显示连接已被重置 一开始发现jenkins在本地可以访问,外网无法访问,本想通过nginx进行反代,实现访问,可是访问后却发现显示的页面为gitlab页面,并且部分图片显示不出。 后面我发现是因为jenkins的端口出
阅读全文
摘要:1.安装 Gitlab目录 安装的同时,还会安装 启动命令 2.修改配置 3.访问 用刚刚配置的端口访问即可 4.其他 4.1Nginx配置目录 按上面的配置, 的配置为 其中,请求会被发到 其实是在 4.2常用命令 4.3推荐链接 "官方文档 https://gitlab.com/gitlab o
阅读全文
摘要:kerberos && openldap 1.install openldap & kerberos server: yum install db4 db4-utils db4-devel cyrus-sasl* krb5-server-ldap -y yum install openldap openldap-servers openldap-clients openldap-devel com
阅读全文
摘要:原理 详细介绍 参考oracle文档: "Kerberos 服务" 安装过程 1.安装krb5 用hosts代替dns 2.修改krb5配置 3.修改ssh配置 修改后需 3.1 3.2 4.创建数据库 5.启动krb5 6.创建用户 kadmin中 用 查看用户 要进kadmin,kdc上可 ,通
阅读全文
摘要:/etc目录下 rc文件均是/rc.d目录中的链接,需要添加自启,只要编辑/etc/rc.local即可
阅读全文
摘要:tarxjb 简单、安全文件拷贝、传输 描述 通过python paramiko库实现简易ssh、sftp执行操作,从而实现文件的远程传输 Github 优点: 可靠传输,文件不易受损 安全传输,避免文件丢失、覆盖 节省带宽,压缩传输 缺点 需要本地中转,对于带宽资源较少的服务器压力大 需要计算md5及解压缩,对cpu占用大 强制退出会失败 详细过程 源主机 检查文件...
阅读全文
摘要:github:easy-copy import os import sys import time import paramiko as pm ''' host格式: { "ip":"127.0.0.1", "port":22, "username":"root", "password":"123456", "file":"filename" } dst...
阅读全文
摘要:scp远程复制 属性变化 需要复制所属关系需要用-p选项 源目录复制之后目的目录的属性: srcdrwxr-xr-x. 2 root root 6 9月 4 16:28 2.txt dstdrwxr-xr-x. 2 root root 6 9月 4 16:30 2.txt 源文件复制之后: src-rw-r--r--. 1 root root 0 9月 4...
阅读全文
摘要:从Sources构建nginx 使用configure命令配置构建,定义了系统的各个方面,包括允许nginx用于连接处理的方法,最后创建了一个Makefile。 configure命令参数: --help:输出帮助信息 --prefix=_path_:定义安装的目录(除lib源文件),默认/usr/local/nginx。 --sbin-path=_path_:设置可执行文件目录,只用在安...
阅读全文
摘要:实例代码 while read line ; do ssh -p20002 $line -o StrictHostKeyChecking=no xxxxxxxxx done < ip.txt while 只循环一次原因: while 读取文本的第一行,然后执行循环,执行到ssh这部时,因为ssh会读取标准输入(stdin),把所有文本都读取了,因此while没有数据,便跳出循环。 解决...
阅读全文
摘要:LVS(Linux Virtual Server)Linux虚拟服务器 LVS集群采用IP负载均衡技术和基于内容请求分发技术。 用户请求发给负载均衡调度器,由负载均衡调度器根据设定的调度算法将请求发给真实服务器。对用户而言,集群是透明的。 LVS集群采用三层结构,其主要组成部分为: 1、负载调度器(load balancer),它是整个集群对外面的前端机,负责将客户的请求发送到一组服务器上...
阅读全文
摘要:TCP 通信时序及状态变迁参考链接:https://www.cnblogs.com/boxker/p/11214886.htmlhttps://blog.csdn.net/miss_ruochen/article/details/80782228https://baijiahao.baidu.com/s?id=1625634527101522856&wfr=spider&for=pchttps:/...
阅读全文
摘要:## 推荐源```https://mirrors.aliyun.com/pypi/simple/ 阿里镜像,速度快、稳定https://pypi.douban.com/simple/ 豆瓣镜像```## 使用方法### 1. 使用时修改```pip install -i [国内镜像地址] [模块名称]```### 2. 修改配置文件修改或创建`~/.pip/pip.conf`文件内容:```[gl...
阅读全文
摘要:参考链接 虚拟机下CentOS7开启SSH连接 记录 我用finalssh连接virtualbox里的centos,发现报出java.net.UnknownHostException 一开始我以为是ssh没开启的缘故,但是无论怎么操作都无法连接。 最后突然发现我主机和名称这两栏写错了,哈哈哈
阅读全文
摘要:简单的playbook 编写playbook #hello.yml #---可写可不写,习惯表示yml的开始 --- #对websrvs里的主机操作 - hosts: websrvs #用root身份登录 remote_user: root #指定命令 tasks: #name是说明性的,说明等下我要做的是什么操作 - name: hello #模块名,后面跟参数,...
阅读全文
摘要:Ansible配置 配置文件:/etc/ansible/ansible.cfg [default] 默认配置 inventory = /etc/ansible/hosts主机清单 library = /usr/share/my_modules库 module_utils = /usr/share/my_module_utils模块路径 remote_tmp = ~/.ansible/tmp...
阅读全文
1

浙公网安备 33010602011771号