poj2533--Longest Ordered Subsequence(dp:最长上升子序列)

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 33943   Accepted: 14871

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
求最长上升子序列:
dp的求法,初始化时能够将a[0]初始化成一个比全部数小的值,或者是将dp[]全清为1,由于最长上升子序列中,会包括自身,所以最小为1
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[12000] , dp[12000] ;
int main()
{
    int i , j , n , max1 ;
    while(scanf("%d", &n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        a[0] = -1 ;
        for(i = 1 ; i <= n ; i++)
            scanf("%d", &a[i]);
        for(i = 1 ; i <= n ; i++)
            for(j = 0 ; j < i ; j++)
                if( a[j] < a[i] && dp[j]+1 > dp[i] )
                    dp[i] = dp[j] + 1 ;
        max1 = 0 ;
        for(i = 1 ; i <= n ; i++)
            max1 = max(max1,dp[i]);
        printf("%d\n", max1);
    }
    return 0;
}

posted @ 2015-02-11 21:27  blfshiye  阅读(97)  评论(0编辑  收藏  举报