Ubuntu 12.04LTS 更换源(转载)

2022-03 实测可用

前言 

本文主要介绍如何为已经不再支持的Ubuntu 12.04LTS 更换源,网上查到的源(很多是13-14年的帖子)都无法直接使用了,例如下面这个

1
2
3
4
deb http://archive.ubuntu.com/ubuntu precise main universe restricted multiverse
deb http://archive.ubuntu.com/ubuntu precise-security universe main multiverse restricted
deb http://archive.ubuntu.com/ubuntu precise-updates universe main multiverse restricted
deb http://archive.ubuntu.com/ubuntu precise-proposed universe main multiverse restricted

最后google到一个github帖子解决了这个问题,由于12.04不受支持了,12.04相关的这些包的资源被移到了old-releases.ubuntu.com域名下,而不是security.ubuntu.com和 archive.ubuntu.com了,因此需要修改源。使用如下命令修改源:

sudo sed -i.bak -r 's/(archive|security).ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

修改后的源:

deb http://old-releases.ubuntu.com/ubuntu precise main universe restricted multiverse
deb http://old-releases.ubuntu.com/ubuntu precise-security universe main multiverse restricted
deb http://old-releases.ubuntu.com/ubuntu precise-updates universe main multiverse restricted
deb http://old-releases.ubuntu.com/ubuntu precise-proposed universe main multiverse restricted

参考:

https://blog.csdn.net/gibbs_/article/details/119212041

https://gist.github.com/dergachev/f5da514802fcbbb441a1

(原文连接:https://www.cnblogs.com/Moooo/p/16044830.html)

posted @ 2023-06-16 17:23  博客园逛逛  阅读(163)  评论(0编辑  收藏  举报