express-partials与express4.x不兼容问题

在express中设置view engine为html,express-partials会导致语法不正确,其实只要做一行代码的改动就可以

 

function renderer(ext){
if(ext[0] !== '.'){
ext = '.' + ext;
}
//新增一行代码
if(ext == '.html') ext = '.ejs';
return register[ext] != null
? register[ext]
: register[ext] = require(ext.slice(1)).render;
};

 

为了方便部署,我将这个方法封装在了nodexcn包中。

可以直接使用npm install nodexcn

 

https://www.npmjs.org/package/nodexcn

http://nodex.cn/

posted @ 2014-06-25 00:38 Birdshover 阅读(...) 评论(...) 编辑 收藏