1069. The Black Hole of Numbers (20)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
#include <iostream>
#include"stdio.h"
#include"stdlib.h"
#include"string.h"
#include"algorithm"
using namespace std;
bool compareChar(char c1, char c2){
    if(c1<c2)
        return false;
    return true;
}
char * stringMinus(char *s1, char *s2){
    for(int i=3;i>=0;i--){
        if(s1[i]>=s2[i]){
              s1[i] = '0'+(s1[i]-s2[i]);
        }
        else{
            s1[i] = '0'+(s1[i]-s2[i]+10);
            if(i>0)
                s1[i-1] -= 1;
        }
    }
    return s1;
}

int main()
{
	int n;
    char s[5]="0000";
    char incr[5];
    scanf("%d",&n);
    int i=0;
    while(n){
    	int x = n%10;
    	s[3-i] = '0'+x;
    	n/=10;
    	i++;
    }
    while(strcmp(s,"0000")!=0){
        sort(s,s+4);
        strcpy(incr,s);
        
        sort(s,s+4,compareChar);
        
        printf("%s - %s = ",s,incr);
        printf("%s\n",stringMinus(s,incr));
        if(strcmp(s,"6174")==0){
        	break;
        }
    }
    return 0;
}


posted @ 2014-03-08 13:32  bingtel  阅读(159)  评论(0编辑  收藏  举报