1074. Reversing Linked List (25)

1074. Reversing Linked List (25)

时间限制
300 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
解题思路:
可能有多个链表干扰,这时候可以用hash来查找在同一个链表里面的节点。
#include"iostream"
#include"stdio.h"
#include"stdlib.h"
#include"string.h"
#include"algorithm"
#include"vector"
using namespace std;

#define MAX 100000
#define LEN 6
typedef struct node{
	char addr[LEN];
	int d;
	char next[LEN];	
}Node;
int main(){
	long N,K;
	char start[LEN];
	scanf("%s%ld%ld",start,&N,&K);
	
	Node b[MAX];/*题目的内存还是很大的,空间换时间*/
	vector<Node> a;
	
	for(int i=0;i<N;i++){
		Node n;
		scanf("%s%d%s",n.addr,&n.d,n.next);
		long index= atol(n.addr);
		b[index] = n;
	}
	/*可能有多个链表,过滤掉不属于start开头链表的噪声节点*/
	long index2 = atol(start);
	while(index2!=-1){
		a.push_back(b[index2]);
		index2 = atol(b[index2].next);
	}
	long size = a.size();
	long len = size/K;
	for(long i=1;i<=len;i++){
    	long start = (i-1)*K;
    	long end = i*K;
    	reverse(a.begin()+start,a.begin()+end);
    }
   	for(long i=0;i<size-1;i++){
		printf("%s %d %s\n",a[i].addr,a[i].d,a[i+1].addr);
	}
	printf("%s %d %d\n",a[size-1].addr,a[size-1].d,(-1));
    return 0;  
}


posted @ 2014-03-09 09:40  bingtel  阅读(127)  评论(0编辑  收藏  举报