在不安装Xcode的情况下安装jekyll

安装jekyll要求Rupy也就罢了,现在还要求先安装Xcode就过分了。

如下方式,跳开Xcode安装jekyll:

1 $ xcode-select --install
2 $ \curl -sSL https://get.rvm.io | bash -s stable
3 $ source ~/.rvm/scripts/rvm
4 $ rvm install ruby --latest
5 $ gem install jekyll

如果需要更新homebrew又遇到了苹果的安全性问题,或者又遇到窠穴尚网问题的话,执行如下安装homebrew:

/bin/zsh -c "$(curl -fsSL https://gitee.com/cunkai/HomebrewCN/raw/master/Homebrew.sh)"

更新过程中报错的话,缺啥补啥,用以下命令检查:

brew doctor

比如 git版本过期,补个:

brew upgrade git

如果报 “Failed to build gem native extension”,去试试更新rybygems,命令行更新果然又不成功,那么就去官网手动更新去:

https://rubygems.org/pages/download

 

如此,以上,相信我,你最后一定会去装Xcode的。

 

参考:

https://arnoutdevos.github.io/Installing-Jekyll-on-OSX-without-Xcode/

https://blog.csdn.net/sourceopen/article/details/106312745?utm_medium=distribute.pc_relevant.none-task-blog-baidujs_title-0&spm=1001.2101.3001.4242

posted @ 2021-03-26 01:10  Reibin  阅读(23)  评论(0编辑  收藏  举报

日志版权保留,转载请注明来自http://www.cnblogs.com/bienfantaisie