hdu 1058 Humble Numbers 丑数(set,优先队列应用)

题目要求,如果一个数的素因数(因数中的素数),只有2,3,5,7,那么这个数称为丑数,输入一个数n,求第n个丑数

题目给出了前20个丑数 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27

里面没有 11,因为11的 因数11是素数,而且11不属于 2,3,5,7; 所以不是丑数;

我们从小到大生成丑数,可以看出对于任意丑数x,2x, 3x,5x,7x,也是丑数,所以我们可以用priority_queue来储存已经生成的丑数,每次取出顶部最小的丑数,再生成4个新的丑数,因为丑数可能有多种生成方式 像(6=2*3 ,6=3*2),所以我们用set来储存生成的丑数;

对stl优先队列有疑惑的同学请猛戳STL优先队列详解


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1058

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19362    Accepted Submission(s): 8463


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000. 【代码如下】
#include <iostream>
#include <queue>
#include <stdio.h>
#include <vector>
#include <set>
using namespace std;
typedef long long ll;
const int coeff[4]={2,3,5,7};
int save[6000];
int main()
{
    priority_queue< ll ,vector<ll>,greater<ll> >Q; // 最小的优先弹出队列
    set<ll>s;
    Q.push(1);
    s.insert(1);
    for(int i=1;;i++)
    {
        ll x=Q.top();Q.pop();
        save[i]=x;
        if(i==5842)
            break;
        for(int j=0;j<4;j++)
        {
            ll x2=x*coeff[j];
            if(!s.count(x2))
            {
                s.insert(x2);Q.push(x2);
            }
        }
    }
    int n;
    while(cin>>n&&n)
    {
        printf("The %d",n);
        int t=n%10;
        int tt=n%100;
        if(tt!=11&&tt!=12&&tt!=13)
        {
            if(t==1)
                printf("st");
            else if(t==2)
                printf("nd");
            else if(t==3)
                printf("rd");
            else
                printf("th");
        }
        if(tt==11||tt==12||tt==13)//11 ,12 ,13 输出都是 th
            printf("th");
            printf(" humble number is %d.\n",save[n]);
    }
    return 0;
}


posted @ 2015-05-05 20:26  编程菌  阅读(210)  评论(0编辑  收藏  举报