POJ3071-Football(概率DP+滚动数组)

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2769   Accepted: 1413

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2
简单的概率题:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int  maxn = 1 << 8;
double p[maxn][maxn];
int n,all;
double dp[2][maxn];
int main(){

    while(cin >> n&&n!=-1){
        all = (1 << n);
        for(int i = 1; i <= all; i++)
            dp[1][i] = 1;
        for(int i = 1; i <= all; i++)
            for(int j = 1; j <= all; j++)
                cin >> p[i][j];
        for(int i = 0; i < n; i++){
            int d = 1<<i;
            for(int k = 1; k <= all; k++){
                dp[0][k] = dp[1][k];
                dp[1][k] = 0;
            }

            int sta=1,ed=sta+d;
            while(ed <= all){
                for(int k = sta; k < ed; k++){
                    for(int a = ed; a < ed+d; a++){
                        dp[1][k] += dp[0][k]*dp[0][a]*p[k][a];
                        dp[1][a] += dp[0][a]*dp[0][k]*p[a][k];
                    }
                }
                sta += 2*d;
                ed = sta+d;
            }
        }
        double ans = dp[1][1];
        int idx = 1;
        for(int i = 2; i <= all; i++){
            if(dp[1][i] > ans){
                ans = dp[1][i];
                idx = i;
            }
        }
        cout<<idx<<endl;
    }
    return 0;
}


posted @ 2016-01-26 19:31  phlsheji  阅读(225)  评论(0编辑  收藏  举报