一个关于Linux升级Python后yum的小问题

前几天在自己的阿里云服务器安装好Python3.5.2之后,顺便删除了原有的/usr/bin/python(因为我知道系统自带的是Python2,而且也会有/usr/bin/python2这个文件,所以直接大胆的删掉了),并且为python3做了软连接,让/usr/bin/python变成的Python3(其实每次用python3运行也可以但我又强迫症必须把常用的改成python)。

但是今天运行yum的时候竟然报错了,我立马想到了之前遇到过的情况。

因为yum是用python2写的,yum的默认解释器设置的是/usr/bin/python如果之前的话还好,因为/usr/bin/python就是python2,但被我改了之后就有问题了,所以果断把yum的默认解释器设置为/usr/bin/python2。

但是,yum刚运行两秒又有了新的问题:

SyntaxError: invalid syntax
  File "/usr/libexec/urlgrabber-ext-down", line 28
    except OSError, e:

语法错误,国外大牛写的文件也会语法错误???这怎么可能

直接vim进去一看。。。果然还是解释器的问题

改正,解决

之前用CentOS6的时候我只改yum就可以了,看来这是CentOS7新加的

posted @ 2017-02-12 02:03  AWM  阅读(190)  评论(0编辑  收藏