UVA 10285 - Longest Run on a Snowboard (记忆化搜索+dp)

Posted on 2013-08-03 21:29  冰天雪域  阅读(173)  评论(0编辑  收藏  举报

Longest Run on a Snowboard

Input: standard input

Output: standard output

Time Limit: 5 seconds

Memory Limit: 32 MB

 

Michael likes snowboarding. That's not very surprising, since snowboarding is really great. The bad thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when you've reached the bottom of the hill you have to walk up again or wait for the ski-lift.

Michael would like to know how long the longest run in an area is. That area is given by a grid of numbers, defining the heights at those points. Look at this example:

 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

One can slide down from one point to a connected other one if and only if the height decreases. One point is connected to another if it's at left, at right, above or below it. In the sample map, a possible slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-...-3-2-1, it would be a much longer run. In fact, it's the longest possible.

Input

The first line contains the number of test cases N. Each test case starts with a line containing the name (it's a single string), the number of rows Rand the number of columns C. After that follow R lines with C numbers each, defining the heights. R and C won't be bigger than 100N not bigger than 15 and the heights are always in the range from 0 to 100.

For each test case, print a line containing the name of the area, a colon, a space and the length of the longest run one can slide down in that area.

Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

 

Sample Output

Feldberg: 7
Spiral: 25
题目分析:从一个点可以向它周围的四个点滑,求一条最长的递减路径,输出最长路径的长度。
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b;
int r,c;
int map[105][105],dp[105][105];
int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
int dfs(int x,int y)
{
	int &ans=dp[x][y]; /*引用dp[x][y]*/
	if(ans)
		return ans;
	bool flag=false;
	for(int i=0;i<4;i++)
	{
		int nx=x+dir[i][0];
		int ny=y+dir[i][1];
		if(nx>=0&&ny>=0&&nx<r&&ny<c&&map[nx][ny]<map[x][y])
		{
			ans=max(ans,dfs(nx,ny)+1);
			flag=true;
		}
	}
	if(!flag) return 1;
	return ans;
}
int main()
{
	char str[100];
	int i,j,MAX,cas;
	scanf("%d",&cas);
	while(cas--)
	{
		scanf("%s%d%d",str,&r,&c);
		for(i=0;i<r;i++)
			for(j=0;j<c;j++)
				scanf("%d",&map[i][j]);
		MAX=0;
		memset(dp,0,sizeof(dp));
		for(i=0;i<r;i++)
			for(j=0;j<c;j++)
				MAX=max(MAX,dfs(i,j));
		printf("%s: %d\n",str,MAX);
	}
	return 0;
}


其中,int &ans=dp[x][y]是对dp[x][y]的引用,用ans的值代替dp[x][y]的值,对ans的操作就相当于对dp[x][y]的操作,ans的值改变以后dp[x][y]的值也会变化。

Copyright © 2024 冰天雪域
Powered by .NET 8.0 on Kubernetes