uva 10194 Football (aka Soccer)

Posted on 2013-07-29 19:42  冰天雪域  阅读(252)  评论(0编辑  收藏  举报

 

Football (aka Soccer) 

 

 

The Problem

Football the most popular sport in the world (americans insist to call it "Soccer", but we will call it "Football"). As everyone knows, Brasil is the country that have most World Cup titles (four of them: 1958, 1962, 1970 and 1994). As our national tournament have many teams (and even regional tournaments have many teams also) it's a very hard task to keep track of standings with so many teams and games played!

So, your task is quite simple: write a program that receives the tournament name, team names and games played and outputs the tournament standings so far.

A team wins a game if it scores more goals than its oponent. Obviously, a team loses a game if it scores less goals. When both teams score the same number of goals, we call it a tie. A team earns 3 points for each win, 1 point for each tie and 0 point for each loss.

Teams are ranked according to these rules (in this order):

 

  1. Most points earned.
  2. Most wins.
  3. Most goal difference (i.e. goals scored - goals against)
  4. Most goals scored.
  5. Less games played.
  6. Lexicographic order.

The Input

The first line of input will be an integer N in a line alone (0 < N < 1000). Then, will follow N tournament descriptions. Each one begins with the tournament name, on a single line. Tournament names can have any letter, digits, spaces etc. Tournament names will have length of at most 100. Then, in the next line, there will be a number T (1 < T <= 30), which stands for the number of teams participating on this tournament. Then will follow T lines, each one containing one team name. Team names may have any character that have ASCII code greater than or equal to 32 (space), except for '#' and '@' characters, which will never appear in team names. No team name will have more than 30 characters.

Following to team names, there will be a non-negative integer G on a single line which stands for the number of games already played on this tournament. G will be no greater than 1000. Then, G lines will follow with the results of games played. They will follow this format:

team_name_1#goals1@goals2#team_name_2

For instance, the following line:

Team A#3@1#Team B

Means that in a game between Team A and Team B, Team A scored 3 goals and Team B scored 1. All goals will be non-negative integers less than 20. You may assume that there will not be inexistent team names (i.e. all team names that appear on game results will have apperead on the team names section) and that no team will play against itself.

The Output

For each tournament, you must output the tournament name in a single line. In the next T lines you must output the standings, according to the rules above. Notice that should the tie-breaker be the lexographic order, it must be done case insenstive. The output format for each line is shown bellow:

[a]) Team_name [b]p, [c]g ([d]-[e]-[f]), [g]gd ([h]-[i])

Where:

  • [a] = team rank
  • [b] = total points earned
  • [c] = games played
  • [d] = wins
  • [e] = ties
  • [f] = losses
  • [g] = goal difference
  • [h] = goals scored
  • [i] = goals against

There must be a single blank space between fields and a single blank line between output sets. See the sample output for examples.

Sample Input

 

2
World Cup 1998 - Group A
4
Brazil
Norway
Morocco
Scotland
6
Brazil#2@1#Scotland
Norway#2@2#Morocco
Scotland#1@1#Norway
Brazil#3@0#Morocco
Morocco#3@0#Scotland
Brazil#1@2#Norway
Some strange tournament
5
Team A
Team B
Team C
Team D
Team E
5
Team A#1@1#Team B
Team A#2@2#Team C
Team A#0@0#Team D
Team E#2@1#Team C
Team E#1@2#Team D

Sample Output

 

World Cup 1998 - Group A
1) Brazil 6p, 3g (2-0-1), 3gd (6-3)
2) Norway 5p, 3g (1-2-0), 1gd (5-4) 
3) Morocco 4p, 3g (1-1-1), 0gd (5-5)
4) Scotland 1p, 3g (0-1-2), -4gd (2-6)

Some strange tournament
1) Team D 4p, 2g (1-1-0), 1gd (2-1)
2) Team E 3p, 2g (1-0-1), 0gd (3-3)
3) Team A 3p, 3g (0-3-0), 0gd (3-3)
4) Team B 1p, 1g (0-1-0), 0gd (1-1)
5) Team C 1p, 2g (0-1-1), -1gd (3-4)

题目大意:给出一场足球比赛(记得名称),有n个球队,m次对抗,(team 1#进球数@进球数#team 2),任务,输出球队排名,按照:

1、得分数;

2、获胜场次;

3、最大净进球;

4、最多进球;

5、最少比赛;

6、队名的字典序;

输出:队名 得分p 场次g, (获胜-平句-失败), 净进球(进球数-失球数)

解题思路:定义一个结构体,包括队名,获胜场次,平句场次,失败场次,进球数,失球数(其他可由这些数据计算出来),对每一条语句进行处理。

具体看代码吧,没什么好讲的,注意细节。

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define N 1005
#define M 305

struct T{
	char name[M];
	int ti, vic, draw, fail, get, lose;
	T(){
		memset(name, 0, sizeof(name));
		ti = vic = draw = fail = get = lose = 0;
	}
};
void change_down(char str[]){
	int len = strlen(str);
	for (int i = 0; i < len; i++)
		if (str[i] >= 'A' && str[i] <= 'Z')
			str[i] += 32;
}

int handle(char str[], T team[], int n){
	char tem[3][M];
	int len = strlen(str), cnt = 0, sex = 0;
	int num[3] = {0};
	for (int i = 0; i < len; i++){
		if (str[i] != '#' && sex == 0)
			tem[0][cnt++] = str[i];
		else if(str[i] == '#' && sex == 0){
			tem[0][cnt] = '\0';
			sex++;
			cnt = 0;
		}
		else if(str[i] != '@' && sex == 1)
			num[0] = num[0] * 10 + str[i] - '0';
		else if(str[i] == '@' && sex == 1)
			sex++;
		else if(str[i] != '#' && sex == 2)
			num[1] = num[1] * 10 + str[i] - '0';
		else if(str[i] == '#' && sex == 2)
			sex++;
		else
			tem[1][cnt++] = str[i];
	}
	tem[1][cnt] = '\0';
	len = cnt = -1;
	
	for (int i = 0; i < n; i++){
        if (len >= 0 && cnt >= 0)
            break;
		if (strcmp(team[i].name, tem[0]) == 0)
            len = i;
        if (strcmp(team[i].name, tem[1]) == 0)
			cnt = i;
	}
    
	if (num[0] > num[1]){
		team[len].vic++;
		team[cnt].fail++;
	}
	else if(num[0] < num[1]){
		team[len].fail++;
		team[cnt].vic++;
	}
	else{
		team[len].draw++;
		team[cnt].draw++;
	}
    
	team[len].get += num[0];
	team[len].lose += num[1];
	team[cnt].get += num[1];
	team[cnt].lose += num[0];
	team[len].ti++;
	team[cnt].ti++;
}

int cmp(const T &a, const T &b){
	if (a.vic * 3 + a.draw > b.vic * 3 + b.draw)
		return 1;
	else if (a.vic * 3 + a.draw < b.vic * 3 + b.draw)
		return 0;
	else if(a.vic > b.vic)
		return 1;
	else if(a.vic < b.vic)
		return 0;
	else if(a.get - a.lose > b.get - b.lose)
		return 1;
	else if(a.get - a.lose < b.get - b.lose)
		return 0;
	else if(a.get > b.get)
		return 1;
	else if(a.get < b.get)
		return 0;
	else if(a.ti < b.ti)
		return 1;
	else if(a.ti > b.ti)
		return 0;
	else{
		char str1[M], str2[M];
		strcpy(str1, a.name);
		strcpy(str2, b.name);
		change_down(str1);
		change_down(str2);
		return strcmp(str1, str2) < 0;
	}
}
int main(){
	int t, n, m;
	char game_name[N], game_data[N];
	scanf("%d%*c", &t);
	while (t--){
        
		// Init.
		memset(game_name, 0, sizeof(game_name));
		T team[M];
        
		// Read.
		gets(game_name);
		scanf("%d%*c", &n);
		for (int i = 0; i < n; i++)
			gets(team[i].name);
		scanf("%d%*c", &m);
		for (int i = 0; i < m; i++){
			memset(game_data, 0, sizeof(game_data));
			gets(game_data);
			handle(game_data, team, n);
		}
        
		sort(team, team + n, cmp);
        
		// Printf.
		puts(game_name);
		for (int i = 0; i < n; i++)
			printf("%d) %s %dp, %dg (%d-%d-%d), %dgd (%d-%d)\n", i + 1, team[i].name, team[i].vic * 3 + team[i].draw, team[i].ti, team[i].vic, team[i].draw, team[i].fail, team[i].get - team[i].lose, team[i].get, team[i].lose);
		if(t)
			printf("\n");
	}
	return 0;}

 

 

 

Copyright © 2024 冰天雪域
Powered by .NET 8.0 on Kubernetes