【概率dp】hdu 3853 LOOPS

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 11659    Accepted Submission(s): 4476


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

 

Sample Input
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

 

Sample Output
6.000
 

 

仍然是概率dp的模板题目

注意分母不能得0!!!

 

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=1005;
int n,m;
double f[maxn][maxn],p[maxn][maxn][3];
int main()
{
    freopen("a.in","r",stdin);
    freopen("a.out","w",stdout);
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(f,0,sizeof(f));
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                for(int k=0;k<=2;k++)
                    scanf("%lf",&p[i][j][k]);
        for(int i=n-1;i>=0;i--)
            for(int j=m-1;j>=0;j--)
            {
                if((i==n && j==m) || p[i][j][0]==1.0) continue;
                f[i][j]=(p[i][j][2]*f[i+1][j]+p[i][j][1]*f[i][j+1]+2)/(1.0-p[i][j][0]);
            }
        printf("%.3lf\n",f[0][0]);
    }
    return 0;    
} 

 

posted @ 2020-11-26 22:06  andyc_03  阅读(80)  评论(0编辑  收藏  举报