Java调用ssl异常(javax.net.ssl.SSLHandshakeException: No appropriate protocol)

今天做升级用了jdk1.8发现java调用SSL的时候,突然一下抛出一个异常

经过一阵瞎搞,最后才发现是因为jdk1.8版本导致SSL调用权限上有问题。

解决办法:找到jdk 1.8安装目录,找到C:\Program Files\Java\jre里面的lib\security 下面有个java.security。找到对应的SSLv3,删除掉,重启项目就好了。(删掉SSLv3就是允许SSL调用)

 

posted @ 2019-05-28 14:43  Andy_alone  阅读(27671)  评论(1编辑  收藏  举报