Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223



#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cstring>
#include <algorithm>
using namespace std;
int father[50005];
int n,m,r;
struct node{
    int u,v,cost;
}edge[50005];
int cmp(struct node a,struct node b){
    return a.cost<b.cost;
}
int found(int x){
    if(x!=father[x])
    father[x]=found(father[x]);
    return father[x];
}
void unite(int x,int y){
    x=found(x);
    y=found(y);
    if(x==y)
    return;
    father[x]=y;
}
bool same(int x,int y){
    return found(x)==found(y);
}
int kruskal(){
    int i,ans;
    struct node e;
    ans=0;
    sort(edge,edge+r,cmp);
    for(i=0;i<r;i++){
        e=edge[i];
        if(!same(e.u,e.v)){
            unite(e.u,e.v);
            ans+=e.cost;
        }
    }
    return ans;
}                                           //kruskal模板
int main(){                                 //将每个人的费用取反,则变为求最小生成森林
    int t,i;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&n,&m,&r);
        for(i=0;i<50005;i++)
        father[i]=i;
        for(i=0;i<r;i++){
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].cost);
            edge[i].v+=n;                   //并查集,将女兵的编号加N
            edge[i].cost*=-1;
        }
        printf("%d\n",10000*(n+m)+kruskal());
    }
    return 0;
}