线段树(询问函数中更新函数)

题目链接

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

InputThere are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.OutputFor each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<cmath>
#include<string>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
struct node{
	ll l,r,max_s;
}a[200000*4]; 
ll h,w,n;
void update(ll k){
	a[k].max_s=max(a[k<<1].max_s,a[k<<1|1].max_s);
	return ;
}
void build(ll k,ll l,ll r){
	a[k].l=l;
	a[k].r=r;
	a[k].max_s=w;
	if(l==r){
		return ;
	}
	ll mid=(a[k].l+a[k].r)>>1;
	build(k<<1,l,mid);
	build(k<<1|1,mid+1,r);
	update(k);
	return ;
}
ll query(ll k,ll x){
	if(a[k].l==a[k].r){
		a[k].max_s-=x;
		return a[k].l;
	}
	ll ans;
	if(x<=a[k<<1].max_s){
		ans=query(k<<1,x);
	}
	else ans=query(k<<1|1,x);
	update(k);
	return ans;
}
int main(){
	while(~scanf("%lld %lld %lld",&h,&w,&n)){
		if(h<n)
		build(1,1,h);
		else build(1,1,n);
		for(ll i=1;i<=n;i++){
			ll x;
			scanf("%lld",&x);
			if(x>a[1].max_s){
				printf("-1\n");
			}
			else printf("%lld\n",query(1,x));
		}
	}
	return 0;
}

  

posted @ 2019-08-07 20:02  AKPower  阅读(144)  评论(0编辑  收藏  举报