hdu 3177 Crixalis's Equipment

Crixalis's Equipment

http://acm.hdu.edu.cn/showproblem.php?pid=3177

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2030    Accepted Submission(s): 815


Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 

 

Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 

 

Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
 

 

Sample Input
2
20 3
10 20
3 10
1 7
10 2
1 10
2 11
 
Sample Output
Yes
No
假设有两件物品
洞穴空间为V(假设能把两个都装下)
物品      需要的存储空间      移动空间
第一件    a1                 b1
第二件    a2                 b2
如果先装第一个后装第二个  需要V是  max(b1,a1+b2)-----(1)
如果先装第二个再装第一个  需要V是  max(b2,a2+b1)-----(2)
我们肯定希望v越小越好
情况1
假设(1)中最大的是a1+b2  ,(2)中最大的是a2+b1 。    如过选方案一  则需满足a1+b2<a2+b1 即b1-a1>b2-a2
 
情况2
假设(1)中最大的是b1 。那么b1>a1+b2>b2   又a2+b1>b1   所以a2+b1>b2 此时(2)中最大的是a2+b1 
        如过选方案一  则需满足 b1<a2+b1(显然成立)和b1>a1+b2   即b1-a1>b2>b2-a2  
 
情况3
假设(2)中最大的是b2 与情况二类似的证明
 
 
综上可知选取方案   依据(bi-ai)从大到小选择
具体代码如下:
#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct as
{
    int a;
    int b;
} p[1010];
int cmp(as s,as q)
{
    return s.b-s.a>q.b-q.a;
}
int main()
{
    int t,v,n,ko,i;
    cin>>t;
    while(t--)
    {
        ko=1;
        cin>>v>>n;
        for(i=0; i<n; i++)
            scanf("%d%d",&p[i].a,&p[i].b);
        sort(p,p+n,cmp);
        for(i=0; i<n; i++)
        {
            if(v>=p[i].b)
                v-=p[i].a;
            else
            {
                ko=0;
                break;
            }
        }
        if(ko)
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
}
View Code

 

 
 

posted on 2013-08-03 20:57  天凉了  阅读(164)  评论(0编辑  收藏  举报

导航