九度OnlineJudge之1029:魔咒词典

题目描述:                       
    哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

    给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
输入:                       

    首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

    [魔咒] 对应功能

    其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以
“@END@”结束,这一行不属于词典中的词条。
    词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:                       
    每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
样例输入:                       
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
样例输出:                       
light the wand
accio
what?
what?
//注意:这一题初拿到的时候觉得挺简单,直接利用关联容器map进行双向字符串hash即可,但是还是WA很多次,这里有几点细节,首先[]之中可能不只一个字符串,也就是说可能会出现[get the moon]等等,其次,根据功能查找魔咒的时候是不能输出两个[ ]的。
#include <iostream>
#include <map>
#include <string>
#include <cstdio>

using namespace std;

int main()
{
    string str;
    map<string,string> m,m1;
    map<string,string>::iterator it;    
    
    while(getline(cin,str),str!="@END@")
    {
        size_t i = str.find("]");
        string a,b;
        a = str.substr(1,i-1);
        b = str.substr(i+2);      
        m.insert(make_pair(a,b)); 
        m1.insert(make_pair(b,a)); 
                                                              
    }  
    int N;
    cin>>N;
    getchar();
    while(N--)
    {
      getline(cin,str);       
      size_t j = str.find("]");      
      if(j!=string::npos)  
      {   
         str = str.substr(1,j-1);                
       it = m.find(str); 
       if(it!=m.end()) cout<<it->second<<endl;
       else
       cout<<"what?"<<endl;        
      }  
      else
      {
        it = m1.find(str);
       if(it!=m1.end())       
         cout<<it->second<<endl;
       else
       cout<<"what?"<<endl;          
      }      
              
    } 
    //system("PAUSE");
    return 0;
}

posted on 2013-09-21 21:13  爱你一万年123  阅读(237)  评论(0编辑  收藏  举报

导航