HDU 6033 Add More Zero (数学)

Description

There is a youngster known for amateur propositions concerning several mathematical hard problems. 

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 00 and (2m1)(2m−1) (inclusive). 

As a young man born with ten fingers, he loves the powers of 1010 so much, which results in his eccentricity that he always ranges integers he would like to use from 11 to 10k10k (inclusive). 

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could. 

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.
 

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer mm, satisfying 1m1051≤m≤105.
 

Output

For each test case, output " Case #xx: yy" in one line (without quotes), where xx indicates the case number starting from 11 and yy denotes the answer of corresponding case.
 
Sample
Sample Input
1
64 
 
Sample Output
Case #1: 0
Case #2: 19 

 

题意:

  给出10^k ≥ 2^m -1,求k的最大整数

思路:

  令10^k = 2^m 两边取对数,得 k = m*log10(2)的整数部分。

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h>
using namespace std;
int main()
{
    int flag = 1,n;
    while(scanf("%d",&n)!=EOF)
    {
        int ans= (n*log10(2));
        printf("Case #%d: %d\n",flag++,ans);
    }
    return 0;
}

 

posted @ 2017-07-30 20:01  爱国呐  阅读(222)  评论(0编辑  收藏  举报