AhDung

/*追求代码质量的野生码农*/

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理
  • 局域网部署,客户机安装时报【部署清单签名的证书或其位置不受信任】:

    在【Internet 属性】里(可运行inetcpl.cpl打开),把服务器内网IP加进【受信任站点】就好,不用管excel信任中心

  • XP等nt5.x系统安装时报【VSTOInstaller.exe无法定位程序输入点GetFileVersionInfoExW】:

    原因是自动下载的runtime有乌龙,说好支持XP,但其实里面用到了nt6.x才有的API,比如上面那个GetFileVersionInfoExW,所以要么【发布>系统必备】中不要勾【创建用于安装系统必备组件的安装程序】,手动下载XP可用的runtime安装(版本10.0.50903,而自动下载的版本以及下载中心的版本都比这个高,都有乌龙),下载地址:

    http://download.microsoft.com/download/C/0/0/C001737F-822B-48C2-8F6A-CDE13B4B9E9C/vstor_redist.exe

    需要注意:卸载错版后相关文件也许会遗留,在【C:\Program Files\Common Files\Microsoft Shared\VSTO\10.0\】,这样你就算装了对版,文件也不会变,问题依旧,所以安装对版之前需检查并清空上述目录。

    要么设置必备组件取用把这个对的runtime,至于如何设置我也不知道。BTW,关于【从与我的应用程序相同的位置下载系统必备组件】方式,像这个vstor应该怎么搞还请高人指点,感

  • 至于报【下载所需文件时发生错误】:

    说明这台电脑访问下载地址有问题,手动下载runtime安装吧,一样注意,XP只能下上面那个。

-EOF-

 

posted on 2018-12-06 12:50  ahdung  阅读(1450)  评论(0编辑  收藏  举报