poj3061 Subsequence【尺取法】

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006

#include<cstdio>
#include<cstring>
#include <iostream>
using namespace std;
const int maxn=100005;
int a[maxn];
int n,s;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&s);
        for(int i=0;i<n;++i)
            scanf("%d",&a[i]);
        int i=0,j=0,ans=n+1,sum=0;
        while(1)
        {
            while(sum<s && i<n)
                sum+=a[i++];
            if(sum<s) break;
            ans=min(ans,i-j);
            sum-=a[j++];
        }
        if(ans>n) ans=0;
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2018-11-06 17:30  浮生惘语  阅读(120)  评论(0编辑  收藏  举报