01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of KKK integers { N1N_1N1​​, N2N_2N2​​, ..., NKN_KNK​​ }. A continuous subsequence is defined to be { NiN_iNi​​, Ni+1N_{i+1}Ni+1​​, ..., NjN_jNj​​ } where 1≤i≤j≤K1 \le i \le j \le K1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KKK (≤10000\le 1000010000). The second line contains KKK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices iii and jjj (as shown by the sample case). If all the KKK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
  • 时间限制:200ms
  • 内存限制:64MB
  • 代码长度限制:16kB
  • 判题程序:系统默认
  • 作者:陈越
  • 单位:浙江大学

题目判定

解题程序
 
 
#include<cstdio>
using namespace std;
int main()
{
    int k,csum=0,sum=-1,x=0,t=0,y=-1;
    int s[10001];
    scanf("%d",&k);
    for(int i=0;i<k;i++)scanf("%d",s+i);
    for(int i=0;i<k;i++){
        csum+=s[i];
        if(csum>sum){
            sum= ;x=t;y=i;
        }
        if(csum<0){
            csum=0;t=i+1;
        }
    }
    if(y==-1)   printf("0 %d %d\n",s[0],s[k-1]);
    else printf("%d %d %d\n",sum,s[x],s[y]);
}

t 表示 成为下一个最大子序列的第一个节点

posted on 2016-09-25 12:02  acmtime  阅读(855)  评论(0编辑  收藏  举报

导航