POJ 3104 Drying(二分答案)

题目链接:http://poj.org/problem?id=3104                   
                                                                                   Drying
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 11128   Accepted: 2865

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

 

 

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

题意: 有n件湿衣服, 现在要把它们烘干(或自然风干), 已知烘干机的效率是每分钟 k 的水分。 自然风干是每分钟 1 的水分。
求最短的烘干时间(整数)。
分析: 0 时间内一定不能烘干。 MAX(水分最多的自然风干用时) 的时间一定能烘干(因为不用烘干,也能风干) 假设 用时 mid 则:
如果a[i]<=mid自然风干就行啦, 如果 a[i]>mid 就要用到烘干机, 假设用 x分钟的烘干机, 则需要满足a[i]-k*x<=mid-x
得出x = ceil(a[i]-mid)/(k-1) 【其中ceil是向上取整的函数,包含在cmath头文件里】 得出各个衣服所需要的烘干时间x,
然后加起来等于res 如果res<mid 则减小mid(用二分法), 否则增大mid。直到求出正确答案。细节详见代码!

二分答案方法的要求:
《1》 能够确定出答案所在的范围。
《2》 答案有在范围内的单调性
《3》 答案是整数(或有一定的精度要求), 而不是十分精确的实数。
二分答案的时间复杂度是logN。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

int n, a[100005], k;
bool check(int mid)
{
    long long res = 0;
    for(int i=0; i<n; i++)
    {
        if(a[i]>mid)
        {
            res+=(int)ceil((double)(a[i]-mid)/(k-1));
        }
    }
    return res<=mid;
} 

int main()
{
    while(scanf("%d", &n)!=EOF)
    {
        int Max=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d", &a[i]);
            if(a[i]>Max) Max=a[i];
        }
        scanf("%d", &k);
        if(k==1)
        {
            printf("%d\n", Max);
            continue;
        }
        int left = 0, right = Max, mid;
        while(right>=left)
        {
            mid = (right+left)>>1;
            if(check(mid)) right = mid-1;
            else left = mid+1;
        }
        printf("%d\n", left);
    }
    return 0;
}

 

 
posted @ 2015-09-07 09:15  草滩小恪  阅读(184)  评论(0编辑  收藏  举报