poj 1159

F - Palindrome
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
char s1[5010],s2[5010],dp[2][5010];
int n,len,maxx;
void ff()
{
      for(int i=1;i<=len;i++)
      {
            for(int j=1;j<=len;j++)
            {
                  if(s1[i-1]==s2[j-1])
                  {
                     dp[i%2][j]=dp[(i-1)%2][j-1]+1;
                  }
                  else
                  {
                     dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
                  }
                  if(maxx<dp[i%2][j])
                        maxx=dp[i%2][j];
            }
      }
}
int main()
{
     scanf("%d",&n);
     scanf("%s",s1);
     len=strlen(s1);
     for(int i=len-1;i>=0;i--)
            s2[len-i-1]=s1[i];
     ff();
     printf("%d\n",len-maxx);
     return 0;
}

  

posted @ 2015-01-27 10:35  心田定则  阅读(166)  评论(0编辑  收藏  举报