(DP) hdu 5000

Clone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 849    Accepted Submission(s): 412


Problem Description
After eating food from Chernobyl, DRD got a super power: he could clone himself right now! He used this power for several times. He found out that this power was not as perfect as he wanted. For example, some of the cloned objects were tall, while some were short; some of them were fat, and some were thin. 

More evidence showed that for two clones A and B, if A was no worse than B in all fields, then B could not survive. More specifically, DRD used a vector v to represent each of his clones. The vector v has n dimensions, representing a clone having N abilities. For the i-th dimension, v[i] is an integer between 0 and T[i], where 0 is the worst and T[i] is the best. For two clones A and B, whose corresponding vectors were p and q, if for 1 <= i <= N, p[i] >= q[i], then B could not survive. 

Now, as DRD's friend, ATM wants to know how many clones can survive at most.
 

 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case: The first line contains 1 integer N, 1 <= N <= 2000. The second line contains N integers indicating T[1], T[2], ..., T[N]. It guarantees that the sum of T[i] in each test case is no more than 2000 and 1 <= T[i]. 
 

 

Output
For each test case, output an integer representing the answer MOD 10^9 + 7.
 

 

Sample Input
2 1 5 2 8 6
 

 

Sample Output
1 7
 

 

Source
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int MOD=1e9+7;
int n,a[5010],dp[5010];
int main()
{
      int tt;
      scanf("%d",&tt);
      while(tt--)
      {
            int sum=0;
            memset(dp,0,sizeof(dp));
            dp[0]=1;
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
            {
                  scanf("%d",&a[i]);
                  sum+=a[i];
            }
            sum=sum/2;
            for(int i=1;i<=n;i++)
            {
                  for(int j=sum;j>=0;j--)
                  {
                        for(int k=1;k<=a[i];k++)
                        {
                              if(j>=k)
                              {
                                    dp[j]=(dp[j]+dp[j-k])%MOD;
                              }
                        }
                  }
            }
            printf("%d\n",dp[sum]);
      }
      return 0;
}

  

posted @ 2015-01-26 08:21  心田定则  阅读(129)  评论(0编辑  收藏  举报