Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1


一开始理解错误 以为总数很大2*1e7超了数组 又因为一共才20只牛 2的20次方应该可以 自己果断用了搜索 但是果断tle
好好理解才知道 就是一个水01背包
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<math.h>
using namespace std;
#define INF 0x3f3f3f3f
#define N 2000003
int dp[2000002];  
int a[123];
int main()
{
    int n,m,s;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        s=0;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            s+=a[i];
        }
        int minn=s;
        for(int i=0;i<n;i++)
            for(int j=s;j>=a[i];j--)
                dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
        for(int i=m;i<=s;i++)
            if(dp[i]>=m)
                minn=min(minn,dp[i]-m);
        printf("%d\n",minn);
    }
    return 0;
}

 

posted on 2016-08-04 19:56  云胡不喜。  阅读(231)  评论(0编辑  收藏  举报