POJ 2828 Buy Tickets(线段树 树状数组/单点更新)

题目链接: 传送门

Buy Tickets

Time Limit: 4000MS     Memory Limit: 65536K

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…
The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.
It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!
People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
    There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

HINT

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

解题思路:

一开始没什么思路,以为就是普通的排队插队问题,准备用数组模拟过程,写到最后发现并非如此,因为每次有人插队进来那么这个人以及他后面的人的序号就会改变,不能实现简单的模拟。想过往线段树靠,但是却不知道怎么靠,百度了题解才恍然大悟。
鉴于插队处于动态的关系,所以逆向思维,考虑总是先确定后面的人的位置,这样题目给出的位置pos就变成了“寻找一个位置,使得这个位置左边的空位置数目为pos”,以第一个样例为例:
把样例倒过来之后是这样的:
2 69
1 33
1 51
0 77
先考虑69号,它的pos是2,说明它插入的时候需要队伍前面有2个人,这样,它就在2号位置上了(从0开始);

再考虑33号,它的pos是1,说明它插入的时候需要队伍前面有1个人,这样,它就在1号位置上了;

再考虑51号,它的pos是1,说明它插入的时候需要队伍前面有1个人,这样,它就在3号位置上了;

再考虑77号,它的pos是0,说明它插入的时候需要队伍前面有0个人,这样,它就在0号位置上了。

所以开一个empty数组保存表示[l,r]区间内的空位置的数目。更新到底是往左子树更新还是右子树更新的原则是:当前需要的空位置数x如果小于[l,mid]区间的空位置数(不包含等于),就往左子树搜(rt<<1),否则往右子树搜(往右子树搜的时候要注意参数x应该减去左子树的空位置数,也就是变为x-empty[rt<<1])。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn = 200005;
int empty[maxn<<2],pos[maxn],val[maxn],ans[maxn];

void PushUp(int rt)
{
	empty[rt] = empty[rt<<1] + empty[rt<<1|1];
}

void build(int l,int r,int rt)
{
	if (l == r)
	{
		empty[rt] = 1;
		return;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUp(rt);
}

void upd(int p,int index,int l,int r,int rt)
{
	if (l == r)
	{
		empty[rt]--;
		ans[l] = val[index]; 
		return ;
	}
	int m = (l + r) >> 1;
	if (empty[rt<<1] > p)	upd(p,index,lson);
	else	upd(p - empty[rt<<1],index,rson);
	PushUp(rt);
}

int main()
{
	int N;
	while (~scanf("%d",&N))
	{
		build(0,N - 1,1);
		for (int i = 0;i < N;i++)
		{
			scanf("%d%d",&pos[i],&val[i]);
		}
		for (int i = N - 1;i >= 0;i--)
		{
			upd(pos[i],i,0,N - 1,1);
		}
		for (int i = 0;i < N;i++)
		{
			i?printf(" %d",ans[i]):printf("%d",ans[i]);
		} 
		printf("\n");
	}
	return 0;
}
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 200005;
int N,c[maxn],pos[maxn],val[maxn],ans[maxn];

void upd(int i,int v)
{
	while (i <= N)
	{
		c[i] += v;
		i += i & -i;
	}
}

int find_kth(int k)
{
	int ans = 0,cnt = 0;
	for (int i = 20;i >= 0;i--)
	{
		ans += (1 << i);
		if (ans > N || cnt + c[ans] >= k)	ans -= (1 << i);
		else	cnt += c[ans];
	}
	return ans + 1;
}

int main()
{
	while (~scanf("%d",&N))
	{
		memset(c,0,sizeof(c));
		for (int i = 1;i <= N;i++)
		{
			upd(i,1);
			scanf("%d%d",&pos[i],&val[i]);
		}
		for (int i = N;i;i--)
		{
			int p = find_kth(pos[i] + 1);
			ans[p] = i;
			upd(p,-1);
		}
		for (int i = 1;i <= N;i++)
		{
			i == 1?printf("%d",val[ans[i]]):printf(" %d",val[ans[i]]);
		}
		printf("\n");
	}
	return 0;
}
posted @ 2016-08-18 00:47  zxzhang  阅读(301)  评论(0编辑  收藏  举报