[poj2411] Mondriaan's Dream (状压DP)

状压DP


Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

此处输入图片的描述

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

此处输入图片的描述

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

Source

Ulm Local 2000


题目大意

给出一个n * m 的矩形,让你用1 * 2 的矩形去填满,问有多少种方案

题解

由于题目给出的数据很小,所以可以直接状压,枚举每一行的状态向后转移。

代码

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

long long dp[13][1 << 11];
long long temp;
int n,m;

void dfs(int i,int p,int k) {
	if (k >= m) {
		dp[i][p] += temp;return;
	}
	dfs(i,p,k + 1);
	if (k <= m - 2 && !(p&(1 << (k + 1))) && !(p&(1 << (k)))) {
		dfs(i,p | 1 << (k + 1) | 1 << k,k + 2);
	}
}

int main() {
	while (cin >> n >> m && n && m) {
		memset(dp,0,sizeof(dp));
		temp = 1;
		int ed = 1 << m;
		dfs(0,0,0);
		for (int i = 1; i < n; i++)
			for (int j = 0; j < ed; j++)
				if (dp[i - 1][j]) {
					temp = dp[i - 1][j];
					dfs(i,~j&((1 << m) - 1),0);
				}
		cout << dp[n-1][ed-1] << endl;
	}
	return 0;
}
posted @ 2016-11-02 22:04  ZegWe  阅读(178)  评论(0编辑  收藏  举报