[poj2247] Humble Numbers (DP水题)

DP 水题


Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence.

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source

Ulm Local 1996


题目大意

一个数,如果它的质因子只有2,3,5,7,则它是一个:Humble Numbers。输入一个n,输出第n个Humble Numbers。

题解

对于一个数,因为质因子只有2,3,5,7,所以它肯定是由前面,某个数乘2,3,5,7得来的。
所以定义dp[i] 表示第i个数,转移方程为:

Dp[i] = min{dp[f2] * 2, dp[f3] * 3, dp[f5] * 5, dp[f7] * 7};

F2,f3,f5,f7是dp[]中的下标。dp[1] = 1;

代码

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn = 5842;
int dp[maxn + 1];

int main() {
	int f2 = 1, f3 = 1, f5 = 1, f7 = 1;
	dp[1] = 1;
	int i = 1;
	while(i++ < maxn) {
		dp[i] = min(min(dp[f2]*2, dp[f3]*3), min(dp[f5]*5,dp[f7]*7));
		if(dp[i] == dp[f2] * 2)f2++;
		if(dp[i] == dp[f3] * 3)f3++;
		if(dp[i] == dp[f5] * 5)f5++;
		if(dp[i] == dp[f7] * 7)f7++;
	}
	int n;
	while(scanf("%d",&n) && n) {
		if(n%10 == 1 && n%100 != 11)printf("The %dst humble number is %d.\n",n,dp[n]);
		else if(n%10 == 2 && n%100 != 12)printf("The %dnd humble number is %d.\n",n,dp[n]);
		else if(n%10 == 3 && n%100 != 13)printf("The %drd humble number is %d.\n",n,dp[n]);
		else printf("The %dth humble number is %d.\n",n,dp[n]);
	}
	
} 
posted @ 2016-11-02 18:11  ZegWe  阅读(380)  评论(0编辑  收藏  举报