[poj2104] K-th Number (主席树)

主席树


Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.


题目大意:

给定n个数,询问 l ~ r 之间第k大的数。主席树裸题。
第 i 棵树保存的是前 i 个点的信息,每次询问就用树 r 减去树 l-1 ,即可得到答案。在树上直接二分,就可以少一个log。

PS: 看qsc视频学到了一种神奇的离散化方法,用vector,很方便,虽然要慢一些咯。

代码

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

const int maxn = 100000 + 5;
int n,m;
int cnt;
int a[maxn];
int rt[maxn];
vector <int>v;

inline int getid(int x){return lower_bound(v.begin(),v.end(),x) - v.begin() + 1;}

struct node{
	int sum;
	int ls,rs;
}nod[maxn * 40];

void update(int l,int r,int &x,int y,int pos){
	nod[++cnt] = nod[y];nod[cnt].sum++;x = cnt;
	if(l == r)return;
	int mid = (l + r) >> 1;
	if(pos <= mid)update(l,mid,nod[x].ls,nod[y].ls,pos),nod[x].rs = nod[y].rs;
	else update(mid+1,r,nod[x].rs,nod[y].rs,pos),nod[x].ls = nod[y].ls;
}

int query(int l,int r,int x,int y,int k){
	if(l == r)return l;
	int mid = (l + r) >> 1;
	int xx = nod[nod[y].ls].sum - nod[nod[x].ls].sum;
	if(xx >= k)return query(l,mid,nod[x].ls,nod[y].ls,k);
	else return query(mid+1,r,nod[x].rs,nod[y].rs,k - xx);	
}

int main(){
	scanf("%d%d",&n,&m);
	for(int i = 1;i <= n;i++)scanf("%d",a+i),v.push_back(a[i]);
	sort(v.begin(), v.end()),v.erase(unique(v.begin(),v.end()),v.end());
	for(int i = 1;i <= n;i++)
		update(1,n,rt[i],rt[i-1],getid(a[i]));
	for(int i = 1;i <= m;i++){
		int a,b,c;scanf("%d%d%d",&a,&b,&c);
		printf("%d\n",v[query(1,n,rt[a-1],rt[b],c) - 1]);
	}
	
	return 0;
} 
posted @ 2016-10-16 20:39  ZegWe  阅读(256)  评论(0编辑  收藏  举报