poj 2377 Bad Cowtractors

Bad Cowtractors
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17411   Accepted: 7059

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

Source

 
思路:最小生成树
AC代码:
#include <iostream>
#include<algorithm>
#include<vector>
#include<cmath>
#include<cstring>
#include<queue>
using namespace std;
#define N_MAX 1010
#define INF 0x3f3f3f3f
typedef long long ll;
struct edge{
   int to,cost;
   edge(int to=0,int cost=0):to(to),cost(cost){}
};
struct P{
   int first,second;
   P(int first=0,int second=0):first(first),second(second){}
   bool operator < (const P &b)const{
      return first>b.first;
   }
};
vector<edge>G[N_MAX];
int d[N_MAX],vis[N_MAX];
int n,m;ll tot=0;
void init(int n){
  for(int i=0;i<n;i++)G[i].clear();
  memset(d,INF,sizeof(d));
  memset(vis,0,sizeof(vis));
  tot=0;
}
void prim(int s){
  priority_queue<P>que;
  que.push(P(0,s));
  d[s]=0;
  while(!que.empty()){
     P p=que.top();que.pop();
     int v=p.second;
     if(d[v]<p.first)continue;
     if(!vis[v]){tot+=d[v];vis[v]=true;}
     for(int i=0;i<G[v].size();i++){
         edge e=G[v][i];
         if(d[e.to]>e.cost){
            d[e.to]=e.cost;
            que.push(P(d[e.to],e.to));
         }
     }
  }
}
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
            init(n);
        for(int i=0;i<m;i++){
          int from,to,cost;scanf("%d%d%d",&from,&to,&cost);from--,to--;
          cost=-cost;
          G[from].push_back(edge(to,cost));
          G[to].push_back(edge(from,cost));
        }
        prim(0);
        bool flag=1;
        for(int i=0;i<n;i++){
            if(!vis[i]){flag=0;break;}
        }
        if(flag)
        printf("%lld\n",-tot);
        else puts("-1");
    }
    return 0;
}

 

posted on 2018-04-12 19:22  ZefengYao  阅读(111)  评论(0编辑  收藏  举报

导航