poj 3666 Making the Grade

Making the Grade
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8794   Accepted: 4117

Description

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|AB1| + |AB2| + ... + |AN - BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

Source

题意:有n个土堆,每个土堆的高度为a1,...,an,现在要增加或者削减土堆的高度,使得n个土堆的高度非严格的单调递增或单调递减。
思路:dp.若某个土堆高度需要改变,改变之后的高度一定在a1,...,an之中的一者(证明?),这样建立一个数组b,存储a1,...,an排序后的值,这样要改变一个土堆的高度,只要在b中选择一个数值即可。
则dp[i][k]:下标到i为止的土堆高度已经单调递增,且最后一个土堆高度为b[k]时,需要的最小花费
动态转移方程:dp[i][j]=min(dp[i-1][k])+abs(b[j]-a[i])  ,其中k的选取必须小于等于j,因为后面的土堆高度一定要比前面的高(非严格)
当然土堆高度也可以单调递减的排列,但其实这和单调递增排列的情况是一样的,即把土堆反转过来就是单调递增的情况。
AC代码:
#include <iostream>
#include<algorithm>
#include<vector>
#include<cmath>
#include<cstring>
using namespace std;
#define N_MAX 2010
#define INF 0x3f3f3f3f
int dp[N_MAX][N_MAX];
int a[N_MAX],b[N_MAX],n;
int main(){
     scanf("%d",&n);
        memset(dp,INF,sizeof(dp));
      for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
      memcpy(b,a,sizeof(b));
      sort(b,b+n);
      for(int i=0;i<n;i++){
         dp[0][i]=abs(b[i]-a[0]);
      }
      for(int i=1;i<n;i++){
          int pre_min=dp[i-1][0];
        for(int j=0;j<n;j++){
            pre_min=min(pre_min,dp[i-1][j]);
           dp[i][j]=min(dp[i][j],pre_min+abs(a[i]-b[j]));

        }
      }
      int min_cost=*min_element(dp[n-1],dp[n-1]+n);
      printf("%d\n",min_cost);

    return 0;
}

 

 

posted on 2018-04-12 18:46  ZefengYao  阅读(180)  评论(0编辑  收藏  举报

导航