HDU5441 Travel (离线操作+并查集)

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2055    Accepted Submission(s): 709


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n cities and m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is x minutes, how many pairs of city (a,b) are there that Jack can travel from city a to b without going berserk?
 

 

Input
The first line contains one integer T,T5, which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n20000,m100000,q5000. The Undirected Kingdom has n cities and m bidirectional roads, and there are q queries.

Each of the following m lines consists of three integers a,b and d where a,b{1,...,n} and d100000. It takes Jack d minutes to travel from city a to city b and vice versa.

Then q lines follow. Each of them is a query consisting of an integer x where x is the time limit before Jack goes berserk.

 

 

Output
You should print q lines for each test case. Each of them contains one integer as the number of pair of cities (a,b) which Jack may travel from a to b within the time limit x.

Note that (a,b) and (b,a) are counted as different pairs and a and b must be different cities.
 

 

Sample Input
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

 

Sample Output
2 6 12
 
题意:q次查询,在n个城市找出之间从一个城市到另一个城市所花时间小于d的城市对数。
思路:一个城市到另一个城市所花时间小于d集合合并。由于时间限制,要离线操作。个人理解,相当于就是打表。
收获:自己思维漏洞好多,要保持程序的健壮性。
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);
#define maxn 5500
#define maxx 26000
#define maxm 160000

struct Edge
{
    int u,v,w;
}edge[maxm];
struct Id
{
    int s, id;
}ans[maxn];
int n,cnt1;

int root[maxx],num[maxx],cnt[maxn];
int vis[maxx];

int cmp(Edge a,Edge b)
{
    return a.w < b.w;
}
int cmp1(Id a, Id b)
{
    return a.s < b.s;
}
int cmp2(Id a, Id b)
{
    return a.id < b.id;
}
void init()
{
    for(int i = 1; i <= n; i++)
    {
        root[i] = i;
        num[i] = 1;
    }
}
int find_root(int x)
{
    if(x != root[x])
        root[x] = find_root(root[x]);
    return root[x];
}
int cot;
void uni(int a, int b)
{
    int x = find_root(a);
    int y = find_root(b);
    if(x != y)
    {
        root[y] = x;
        int p1 = num[x];
        int p2 = num[y];
        cot -= p1*(p1-1);
        cot -= p2*(p2-1);
        num[x] += num[y];
        cot += num[x] * (num[x]-1);
        num[y] = 0;
    }
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int m,q;
        scanf("%d%d%d", &n, &m, &q);
        for(int i = 0; i < m; i++)
            scanf("%d%d%d", &edge[i].u, &edge[i].v, &edge[i].w);
        init();
        sort(edge, edge+m, cmp);
        for(int i = 0; i < q; i++)
        {
            scanf("%d", &ans[i].s);
            ans[i].id = i;
        }
        sort(ans, ans+q, cmp1);
        memset(vis, 0, sizeof vis);
        cnt1 = 0;
        int cnt2 = 0;
        cot = 0;
        //memset(cnt, 0, sizeof cnt);
        for(int i = 0; i < m; i++)
        {
            if(cnt2 == q)
                break;
//            if(edge[i].w <= ans[cnt2].s)
//            uni(edge[i].u, edge[i].v);
//            else
                for(int j = cnt2; cnt2 < q; cnt2++)
                {
                    if(edge[i].w <= ans[cnt2].s)
                    {
                        uni(edge[i].u, edge[i].v);
                        break;
                    }
                    ans[cnt2].s = cot;
                }

        }
        int temp;
        if(cnt2 == 0)
            temp = cot;
        else
           temp = ans[cnt2-1].s;
        if(cnt2<q)
            for(int i = cnt2; i < q; i++)
                ans[i].s = temp;

        sort(ans, ans+q, cmp2);
        for(int i = 0; i < q; i++)
            printf("%d\n", ans[i].s);
    }
    return 0;
}

 

posted @ 2015-09-24 17:30  JoneZP  阅读(270)  评论(0编辑  收藏  举报