Highway Project

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward, the emperor of the Marjar Empire, wants to build some bidirectional highways so that he can reach other cities from the capital as fast as possible. Thus, he proposed the highway project.

The Marjar Empire has N cities (including the capital), indexed from 0 to N - 1 (the capital is 0) and there are M highways can be built. Building the i-th highway costs Ci dollars. It takes Di minutes to travel between city Xi and Yi on the i-th highway.

Edward wants to find a construction plan with minimal total time needed to reach other cities from the capital, i.e. the sum of minimal time needed to travel from the capital to city i (1 ≤ i ≤ N). Among all feasible plans, Edward wants to select the plan with minimal cost. Please help him to finish this task.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers NM (1 ≤ NM ≤ 105).

Then followed by M lines, each line contains four integers XiYiDiCi (0 ≤ XiYi < N, 0 < DiCi < 105).

Output

For each test case, output two integers indicating the minimal total time and the minimal cost for the highway project when the total time is minimized.

Sample Input

2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 1 1
2 3 1 2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 2 1
2 3 1 2

Sample Output

4 3
4 4

题目大意:
给你 T 组测试数据, 每组测试数据有个 n 和 m,表示有 n 个点 m 条边,这 m 条边分别有它修建的价值和从这条边上通过的时间,现在问题来了, 问你如何修建能够让它需要的时间最小, 在时间最小的前提下, 让修路花费的时间也尽可能的小, 最后求从 0 点到各个点的总时间和建路花费的费用


先将起始点加到队列里面, 然后访问起始点能够到达的点把满足要求的点在加到队列里面, 依次直到队列里面没有点了, 就结束, 此时dist里面存的值,就是自己想要的值


#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
using namespace std;

typedef long long LL;
#define N 110000
#define met(a,b) (memset(a,b,sizeof(a)))
const LL INF = (1ll<<60)-1;


struct node
{
    LL v, cost, time, next;
}a[N<<2];

LL Head[N], cnt, sumc, sumt, distc[N], distt[N];
int n, m, vis[N];

void Init()
{
    cnt = 0;
    met(Head, -1);
}
void Add(int u, int v, int cost, int time)
{
    a[cnt].v = v;
    a[cnt].cost = cost;
    a[cnt].time = time;
    a[cnt].next = Head[u];
    Head[u] = cnt++;

    swap(u, v);

    a[cnt].v = v;
    a[cnt].cost = cost;
    a[cnt].time = time;
    a[cnt].next = Head[u];
    Head[u] = cnt++;
}

void spfa()
{
    int u, v, cost, time, i;
    met(vis, 0);
    vis[0] = 1;

    for(i=0; i<n; i++)
    {
        distt[i] = INF;
        distc[i] = INF;
    }
    distt[0] = distc[0] = 0;

    queue<int>Q;
    Q.push(0);

    while(Q.size())
    {
        u = Q.front(), Q.pop();

        for(i=Head[u]; i!=-1; i=a[i].next)
        {
            v = a[i].v;
            cost = a[i].cost;
            time = a[i].time;

            if((distt[v]>distt[u]+time)||(distt[v]==distt[u]+time && distc[v]>cost))
            {
                distt[v] = distt[u]+time;
                distc[v] = cost;

                if(!vis[v])
                {
                    vis[v] = 1;
                    Q.push(v);
                }
            }
        }
        vis[u] = 0;
    }

    sumc = sumt = 0;

    for(i=1; i<n; i++)
    {
        sumc += distc[i];
        sumt += distt[i];
    }
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int  i;
        LL u, v, cost, time;

        Init();

        scanf("%d%d", &n, &m);

        for(i=1; i<=m; i++)
        {
            scanf("%lld%lld%lld%lld", &u, &v, &time, &cost);
            Add(u, v, cost, time);
        }

        spfa();

        printf("%lld %lld\n", sumt, sumc);
    }
    return 0;
}

 

posted on 2016-04-25 10:39  栀蓝  阅读(318)  评论(0编辑  收藏  举报

levels of contents