http://acm.hust.edu.cn/vjudge/contest/view.action?cid=98634#problem/B(acm14)

 

Description

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <map>

using namespace std;

#define N 200005

int main()
{
    long long T, iCase=1;

    scanf("%d", &T);

    while(T--)
    {
        long long n, i;

        scanf("%lld", &n);


        long long a, num = 1, sum = n, pre=n;

        for(i=2; i<=n; i++)
        {
            a = n/i;
            num += (pre-a);
            sum += (pre-a)*(i-1);

            if(num==n)
                break;

            num++;
            sum += a;
            if(num==n)
                break;

            pre = a;
        }

        printf("Case %lld: %lld\n", iCase++, sum);
    }

    return 0;
}

 

posted on 2015-11-08 15:58  栀蓝  阅读(160)  评论(0编辑  收藏  举报

levels of contents